Upgraded to Rails 3.1.1 and MongoID 2.3.1